My Leopard Has Lost Its Spots

I run a mostly Windows-only setup at home these days. My home setup consists of:

  • an SBS2003 server mostly for Exchange mail, which also runs FreeBSD in a virtual machine to keep some older services running on Apache (primarily the redirector from my domain to Live Spaces and my subversion repository).
  • a Windows Home Server, which has taken over the file server functionality from SBS2003, as I like its more flexible file replication
  • a media center PC running Vista Ultimate
  • a kitchen internet appliance running Windows CE
  • Vista Ultimate PCs for each of my kids (and a laptop for the wife)
  • a desktop PC and a Tablet PC for me with Vista Ultimate
  • an oldish Mac Mini G4 which was running Leopard

I'm mostly pretty happy with Vista. I love the Media Center especially now with an HDHR attached (we only get \$15 limited cable). My kids have pretty good success running old games; I'd say about 90% of their games run on Vista, and considering some of them harken back to Windows 3.1 that's not too shabby. The parental controls made Vista a no-brainer for their machines. The Mac is the odd one out - but I keep it around mostly because I love Handbrake on the Mac; its the best way to move my DVDs into a library that is easily accessible from the Media Center. There is a Windows port - and I could run it way faster on my desktop - but the lack of a video preview to determine things like crop and de-interlace settings take away much of the coolness compared to the Mac version.

When Leopard came out I installed it on my Mini - even though I didn't really need to. I'm not really the target market, and to me it's only been mildly annoying; it hasn't added any value. But I'm going back to Tiger. Tonight I came home and my Mac had a message on the screen saying I needed to restart my compute - and it explicitly instructed me to do so by power cycling, rather than shutting down (I was locked out of any alternatives anyway). Since power cycling it does not finish booting. I get the Apple logo, then a blue screen with just a mouse cursor.

I know we go through cycles of copying each other, but I never thought Apple would want to emulate the BSOD. I only hope I can manage to do a non-destructive re-install of Tiger so as not to lose some files I had on the machine.

Comments

Comments powered by Disqus